1

I indexed a shared drive just fine and can find the files am looking for using the search portal, but when I search using the search bar on the pages I have no results

Thank's in advance

3

The problem is that the site search box by default directs the search query to the SharePoint Foundation Search page at ~site/_layouts/15/osssearchresults.aspx. This is not the same as a Enterprise Search Center site, which is what you need to search the indexed content on your file shares.

To direct search queries to the Enterprise Search Center site (I assume it exists), go to Site Settings > Search Settings and specify the URL address of the search center.

enter image description here

You can configure the search box for all sites in the site collection at ~site/_layouts/15/enhancedSearch.aspx?level=sitecol and/or indivually for each site at ~site/_layouts/15/enhancedSearch.aspx?level=site

  • Thank you for your replies I did what you said and am waiting for 30 min (as mentioned before changes may apply) then I'll inform you if it worked or not – Mohamed Ayach Jan 18 '17 at 16:50
  • 1
    Awesome it worked ! – Mohamed Ayach Jan 18 '17 at 17:15
2

This is expected behaviour, site search will automatically return results just for this site. In order to achieve what you want you need to connect site to the search portal. Go to site settings--> search settings--> and use option "Send queries to custom results page URL" in the results enter the SearchPortalURL/Pages/Results.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.