0

I have been trying to update one piece of code saved in siteassets. For some reason, if I try to drag and drop the updated CSS code in, the pop up shows: enter image description here I click "replace it" and the modified date shows "a few seconds ago"... However, when I open the file, I find that my changes were not made. I have tried to use the "upload" button, and the same outcome. I even synced the library to my computer, and drag and dropped the file from file explorer, to no avail. Why can't I change this file? This has been a reoccurring issue with Javascript files saved in siteassets in the past. Even if I delete the file, and drag the new version in, it doesn't keep the changes. I'm thoroughly confused. Any ideas?

1

It seems to be cache issue.

Open your CSS file in browser. Please do Ctrl-F5 to force a cache refresh.

F5 may give you the same page even if the content is changed, because it may load the page from cache. Ctrl-F5 forces a cache refresh, and will guarantee that if the content is changed, you will get the new content. What requests do browsers' “F5” and “Ctrl + F5” refreshes generate..

  • I looked at it today and the change seems to have gone through, if I use the Ctrl+F5 it does fix the issue thank you – Sabien Ambrose Jan 18 '17 at 16:25
1

If it is updating the modified dates, it sounds like it is working but is merely a browser cache issue. Have you tried doing a hard refresh and/or clearing your browser cache or trying in a private browser tab?

Doing this should resolve the issues you are facing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.