I receive the message "could not save the list changes to the server" every time I try to add a new form to my list in Sharepoint Designer 2013.

It happens regardless of the form type.

I've tried the following:

  • Removed and re-added the list to the site collection, then reopened the site in Designer to try again
  • Done the above after deleting all lists, and then deleting from both recycle bin views on the site
  • Restarted the server

None of the above helped so did the following:

  • As the lists contained custom site-columns, I deleted all lists from the site (including recycle bin)
  • Created a new list with text field: title
  • Re-opened the site in Designer and tried again. Same error.

UPDATE - tried the following also: - Deleted the site collection entirely - custom columns and all. - Created a new site collection and added a list with the basic site-columns - tried to add a form - Problem perists - same error

I've looked over the following similar questions:

Points to note:

  • In Sharepoint Designer, when prompted for credentials, I'm entering the details of a site-collection administrator.
  • I have some custom site-columns defined in the site collection. No special chars in the names and all are standard enough datatypes (money, date, text)
  • The problem does not occur when adding a view to a list.

I'm relatively new to Sharepoint, so might be missing something here. Any help appreciated.

  • do you have duplicate columns? Jan 17, 2017 at 11:13
  • @dsouzajoel22 Do you mean duplicates in the list or the site? On the site level, there are title and descroption site-columns under "custom columns" alright, and they exist elsewhere too
    – dbr
    Jan 17, 2017 at 11:27
  • petestilgoe.com/2011/01/10/… this may help you Jan 17, 2017 at 11:28
  • @dsouzajoel22 - Just deleted the site collection entirely and created a new site - no custom columns. Added a list and now am having the same issue in Designer
    – dbr
    Jan 17, 2017 at 11:55
  • I had the same problem and I resolved it by deleting all the content of the folder "C:\Users\user1\AppData\Local\Microsoft\WebSiteCache" where User1 is the actual user. Jan 17, 2017 at 11:58

5 Answers 5


If anyone has landed here in 2020 onwards looking for the answer, the reason is that Microsoft have deprecated this feature.



Ususally it depends on some lookup column. I had it several time and all "fixes" on cache etc etc were useless. Check all lookup columns if all are hooking on existing fields/lists.


I've resolved this, using a combination of this answer and this answer

In powershell:

  • Ran command Get-SPFeature | Sort -Property Id
  • Searched for a Feature with the property GUID "e374875e-06b6-11e0-b0fa-57f5dfd72085" (name: "Developer")
  • Ran the following command to disable the feature: Disable-SPFeature -Identity "e374875e-06b6-11e0-b0fa-57f5dfd72085" -Url http://sitecollectionurl
  • Cleared the contents of C:\Users\\AppData\Local\Microsoft\WebsiteCache\
  • Reopened the site collection in designer and can add forms to lists without an issue now.
  • IS this a site collection feature? Because I have SC rights not farm admin rights, If SC I can change via JSOM , Client side powershell Mar 15, 2021 at 11:23

In my case I was linking to an empty external table. It was not until I added data to the table that I was able to create forms.


If you just passed the upgrade from previous version of SharePoint 2010 or you installed CU, you seem to face this issue. But it could be issue on only some subsites, not all. The problem is, that on the affected site there is wrong setting of HomePage. Fidler would tell you the same. And solution?

  1. create SitePages as Wiki library, if it is missing. If not, continue to next step
  2. create any wiki page, if it is missing any. If not, continue to next step
  3. open any page from this Wiki library in the web browser, on the page tools, set the page as homepage.
  4. get back to the previous homepage and again, set it back as a homepage. Try to open Designer and create any custom form.

My issue is, that I don't use wikipage as homepage and I delete sitepages library very often. After upgrade to MSF2013 there is some check in SPD and it is not possible to pass it. After I changed the homepage back from wiki library page, I can again delete the wiki library and work with no issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.