1

I receive the message "could not save the list changes to the server" every time I try to add a new form to my list in Sharepoint Designer 2013.

It happens regardless of the form type.

I've tried the following:

  • Removed and re-added the list to the site collection, then reopened the site in Designer to try again
  • Done the above after deleting all lists, and then deleting from both recycle bin views on the site
  • Restarted the server

None of the above helped so did the following:

  • As the lists contained custom site-columns, I deleted all lists from the site (including recycle bin)
  • Created a new list with text field: title
  • Re-opened the site in Designer and tried again. Same error.

UPDATE - tried the following also: - Deleted the site collection entirely - custom columns and all. - Created a new site collection and added a list with the basic site-columns - tried to add a form - Problem perists - same error

I've looked over the following similar questions:

Points to note:

  • In Sharepoint Designer, when prompted for credentials, I'm entering the details of a site-collection administrator.
  • I have some custom site-columns defined in the site collection. No special chars in the names and all are standard enough datatypes (money, date, text)
  • The problem does not occur when adding a view to a list.

I'm relatively new to Sharepoint, so might be missing something here. Any help appreciated.

  • do you have duplicate columns? – dsouzajoel22 Jan 17 '17 at 11:13
  • @dsouzajoel22 Do you mean duplicates in the list or the site? On the site level, there are title and descroption site-columns under "custom columns" alright, and they exist elsewhere too – dbr Jan 17 '17 at 11:27
  • petestilgoe.com/2011/01/10/… this may help you – dsouzajoel22 Jan 17 '17 at 11:28
  • @dsouzajoel22 - Just deleted the site collection entirely and created a new site - no custom columns. Added a list and now am having the same issue in Designer – dbr Jan 17 '17 at 11:55
  • I had the same problem and I resolved it by deleting all the content of the folder "C:\Users\user1\AppData\Local\Microsoft\WebSiteCache" where User1 is the actual user. – dsouzajoel22 Jan 17 '17 at 11:58
1

Ususally it depends on some lookup column. I had it several time and all "fixes" on cache etc etc were useless. Check all lookup columns if all are hooking on existing fields/lists.

0

I've resolved this, using a combination of this answer and this answer

In powershell:

  • Ran command Get-SPFeature | Sort -Property Id
  • Searched for a Feature with the property GUID "e374875e-06b6-11e0-b0fa-57f5dfd72085" (name: "Developer")
  • Ran the following command to disable the feature: Disable-SPFeature -Identity "e374875e-06b6-11e0-b0fa-57f5dfd72085" -Url http://sitecollectionurl
  • Cleared the contents of C:\Users\\AppData\Local\Microsoft\WebsiteCache\
  • Reopened the site collection in designer and can add forms to lists without an issue now.
0

In my case I was linking to an empty external table. It was not until I added data to the table that I was able to create forms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.