0

I am trying to activate a feature using PowerShell Enable-SPFeature but receive the following error:

Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url

I can see that the feature is available for activating in the ManageFeatures.aspx page of the site but it appears the PowerShell does not see it because it is not present when I execute the Get-SPFeature cmdlet.

1
  • 2
    Can you post the PowerShell command you are executing? Sep 30, 2011 at 1:01

2 Answers 2

2

Is it a Site feature, or a Web feature? If it's a Web, try

$w = Get-SPWeb http://yoursite/yourweb
Get-SPFeature -Web $w 

Then use the Guid to activate the feature

Enable-SPFeature -Identity "00bfea71-c796-4402-9f2f-0eb9a6e71b18" -Url http://yoursite/yourweb

Have you started a new Powershell window? Sometimes Powershell keeps some weird cache. I struggled with some web templates I was deploying, all files were in the right place, all deployed everywhere, and the Get-SPWebTemlate was still not showing them in the window that activated the feature that deployed them. Every new PS window would get them though

Hope it helps, Cheers, JC

4
  • +1 for the weird cache
    – Steve B
    Sep 30, 2011 at 5:11
  • It is a Site Feature - a Web Part. The Event Receiver is adding a connection string entry.
    – ChiliYago
    Sep 30, 2011 at 16:30
  • Can you give us some detail on your farm configuration? Are the feature files deployed in the same server where you're trying to run the PS command? Oct 1, 2011 at 2:00
  • his is just a single instance dev machine. I am developing a web part that needs a connection string. My event receiver adds that to the web.config. Thus the access denied error for whatever reason.
    – ChiliYago
    Oct 2, 2011 at 13:35
0

The STSADM command seems to not have the same security issue since executing it to enable my feature does not produce the same access denied error...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.