0

My User Profile Service Application (NOT the synchronisation Service) stopped working so I deleted and tried to recreate it using PowerShell.

I have tried a number of times - deleting it before I start again (and the Databases). Using the Central Administration deletion does not work so I use a mixture of STADM -o deleteconfigurationobject -Id {ID of USer Profile Service Application} and then a PowerShell script to delete the timer jobs. (PowerShell Remove-SPServiceApplication fails with a The SPPersistedObject with id, {Id}, could not be found.)

I have tried creating the User Profile Service Application using Central Administration and using PowerShell (running under the \SP_Farm account so the schema on SYncDB is correct).There are no CRITICAL or UNEXPECTED items in the Logs.

The last relevant item in the ULS logs is a message saying it is waiting for a timer job to finish.

"Waiting for service application instance provisioning job to complete for service application with name 'User Profile Service' and type 'Microsoft.Office.Server.Administration.UserProfileApplication' "

The SPTimer service is still running.

I am running SP2013 with the September 2016 CU.

What am I missing ?

  • is ur farm admin account is in the Local admin on the server where you want to provision the UPA – Waqas Sarwar MVP Jan 12 '17 at 19:08
  • yes it is. (the farm account is temporarily in the Local Administrators Group - I will remove it when I get this working) Farm Account has Log on Locally rights as well – Nigel Price Jan 12 '17 at 20:21
  • Make sure User profile service is running on one of the SharePoint server in the farm, before you start provision the UPS? – Waqas Sarwar MVP Jan 12 '17 at 20:23
  • I have got not as far as the User Profile Synchronisation Service yet. This is the User Profile Service Application. – Nigel Price Jan 12 '17 at 20:27
  • Have you tried to start the upa instance(from central admin> manage services) first then try to provision it? – Waqas Sarwar MVP Jan 12 '17 at 20:32
0

THis is the output from the UL:SViewer :-

User Profile Application 'User Profile Service Application' installation complete. Updating SPPersistedObject SPServiceApplicationInstanceProvisioningJobDefinition Name=User Profile Service Application. includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) Updating SPPersistedObject SPServiceApplicationInstanceProvisioningJobDefinition Name=User Profile Service Application. Version: 266128 Ensure: False, HashCode: 13459742, Id: 5bc277d5-fe58-4b55-9f7b-2380815be9ff, SPTimerJobAsyncResult '5bc277d5-fe58-4b55-9f7b-2380815be9ff': Created SPTimerJobAsyncResult. SPTimerJobAsyncResult '5bc277d5-fe58-4b55-9f7b-2380815be9ff': SPTimerJobAsyncResult.End() invoked. SPTimerJobAsyncResult '5bc277d5-fe58-4b55-9f7b-2380815be9ff': Timer job has not completed. Blocking until job completes Blocking until timer job '5bc277d5-fe58-4b55-9f7b-2380815be9ff' has completed.

20 minutes later

SPTimerJobAsyncResult '5bc277d5-fe58-4b55-9f7b-2380815be9ff': An error occurred while waiting for completion: System.Threading.ThreadAbortException: Thread was being aborted.

  • Hi and welcome to SharePoint.StackExchange Nigel Price. You have posted a new question in the answer field, and I would advise you to ask a new question instead. Use the "Ask Question" button in the upper right corner. You can always find out more in the Help Section. – Benny Skogberg Jul 17 '18 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.