0

Until drop 6 I am able to Spfx web parts into sharepoint classic pages. I tried to create new spfx webpart using RC0 release and deployed through app catalog. I installed the spfx app into site collection and try to add the webpart into classic SharePoint pages the webpart was not displayed under webpart gallery.

  • I would believe more information is due – Paul Strupeikis Jan 12 '17 at 9:38
  • @PaulStrupeikis i am also facing the same issue. I have updated my Project to RC0 and its working in _layouts/15/workbench.aspx .Later i wanted to add this webpart to SharePoint Page from Page Library.For that as i did before i Bundled and Package the solution.it created the sppkg file and uploaded to App Catalog.I was able to install this app in my site but when i went to the page in Edit Mode and try to add the webpart from Webpart gallery, Client webpart is not available in Custom Folder to add to the page. Please help me with this issue. – vinit kumar Jan 16 '17 at 6:23
  • @vinitkumar after you registred your app in AppCatalog then you need to go Site Contents view and from the menu choose New > App option. The newly installed .spapp/.sppkg should be displayed as the first app, click on your application and then your app will shows on webpart Gallery – Melad Francis Jan 17 '17 at 13:10
  • @MiladFrancis , Thanks for responding but i already did the same as you mentioned. and until drop 6, webpart was displayed in "Custom" Folder but after RC0 update we are not able to see the webpart in "Custom". I wanted to add webpart in Classic SharePoint page as i have done till drop 6. – vinit kumar Jan 17 '17 at 13:36
  • hmm... it's looks like RC0 isn't on the tenant yet – Melad Francis Jan 17 '17 at 13:43
-1

Apparently some tenants didn't get the fix - can you check one last time?

Check it out this issue

https://github.com/SharePoint/sp-dev-docs/issues/343#issuecomment-273634635

thanks!

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.