I have an SP 2016 farm and I have just configured workflow. I've set up a workflow to run upon creation of an item (for a holiday request form) however looking at the workflow status, I see the following error. I haven't been able to google-fu a fix for this and would appreciate it if anyone could shed any light on the problem.

Activity in progress Retrying the last request. Next attempt scheduled in less than one minute. Details of the last request: HTTP Unauthorized to https://intranetaddresss/subsite/_api/web/lists(guid'GUID')Correlation ID: GUID Instance ID: GUID Access denied. You do not have permission to perform this action or access this resource.

The first step in the workflow is to change the workflow status to 'Pending' however it doesn't even get to that stage which tells me the Workflow itself isn't actually starting to run.

I've given the user submitting the form full control over the list, however, this has not helped.

I've tried searching ULSViewer for that correlation ID and find nothing.

Can someone help?

  • A common mistake one does creating a workflow is to run it with an administration account that doesn't have permission on the list. Please check by which account (SP_Service?) your running the workflow and what permission that account have on the list.
    – Benny Skogberg
    Commented Jan 9, 2017 at 12:54
  • @BennySkogberg Thanks for replying. I've checked and the service account I configured Workflow with initially did not have permissions on the list. I have temporarily directly gave it Full Control to the list however that's not helped. I've tried retrying and creating a new item, both of which are still stuck. Do you have any other ideas?
    – Joe129
    Commented Jan 9, 2017 at 13:03
  • A little bit late but you might want to look at this one : docs.microsoft.com/en-us/sharepoint/dev/general-development/…
    – JesseJ
    Commented Dec 8, 2017 at 23:35

3 Answers 3


Add the Service account to the User Profile Service according to the troubleshooting section of Install and configure workflow for SharePoint Server 2013

"The user who deploys and runs a workflow must be added to the User Profile service. Check the User Profile service application page in Central Administration to confirm that the user you are using to validate workflow installation is in the User Profile service."

  • I have just checked and can confirm that the profile for the service account is synced to SharePoint by the user profile service. I've went to Central Admin>Service Applications>User Profile Service Application>Manage User Profiles>Searched for account and it appears.
    – Joe129
    Commented Jan 9, 2017 at 13:51
  • OK. And if you co to http://CentralAdminURL:port/_admin/WorkflowServiceStatus.aspx you have Workflow is Connected as a result?
    – Benny Skogberg
    Commented Jan 9, 2017 at 13:57
  • Correct. Shows "Workflow is Connected". In SharePoint Designer I have the option for SharePoint 2013 Workflow as well.
    – Joe129
    Commented Jan 9, 2017 at 13:58
  • OK, good. And if you allow to start the workflow manually, and do so with a regular user, you get the same result?
    – Benny Skogberg
    Commented Jan 9, 2017 at 14:00
  • Logged in user, create item then go to item>workflows. Interestingly enough I get "this item has no workflows to start". Logged in as domain admin, go to item>workflow and I do have the workflow available.
    – Joe129
    Commented Jan 9, 2017 at 14:30

In SPD just check that you've not accidently checked the "Require Manage List permissions" checkbox on the workflow start options. Can you also confirm if the users have custom permission levels or just OOB ones?

enter image description here

  • 1
    I've just checked in SPD, I don't even have that option. All I have is; Allow this workflow to be manually started (checked), start workflow automatically when item is created (unchecked - due to testing with Benny Skogberg) and start workflow automatically when an item is changed (unchecked). The users have custom permission level access to the site (although the custom permission gives read and a few others such as client integration features). Then on this list, for testing I have provided full control.
    – Joe129
    Commented Jan 9, 2017 at 17:16

I had the same problem. I solved by removing the following check from the Workflow Settings: enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.