0

I am carrying out a migration from one AD to another. I have matching versions and have dismounted and moved the original databases over.

Now I'm looking at restoring the applications.

If, in the shell, I run get-spsolution, I can see there are 7 solutions, only one of which deployed is true, so i need to redeploy these apps. Great.

I have taken the solutionID of the first app and tried

 install-spsolution e809e62-4a1b-4757-8ad0-blahblah -GACDeployment

It errors immediately and tells me that

This solution contains resources scoped for a Web application and must be deployed to one or more web applications.

I suspect this may mean I have to get the re-deploy order correct, but that is, at best, an uneducated guess.

Can one of you fine people point me in the right direction?

2

You have to mention the web application name in your command like this

Install-spsolution e809e62-4a1b-4757-8ad0-blahblah -WebApplication "URL of webapplication" -GACDeployment

Or you can use -AllWebapplications instead of webapplication if more than one web application in farm.

Test it now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.