1

I'm having trouble configuring my Office Web Apps.

I have set the Wopi Zone as follows: Set-SPWopiZone external-https

But when I look at my bindings, they all list the WopiZone as internal-https:

...
Application     : WordPdf
Extension       : PDF
ProgId          :
Action          : embedview
IsDefaultAction : False
ServerName      : servername
WopiZone        : internal-https

I've run this command to show that they are all internal-https:

PS C:\Users\username> get-spwopibinding | group wopizone

Count Name                      Group
----- ----                      -----
  185 internal-https            {Microsoft.SharePoint.PowerShell.SPWopiBinding, Microsoft.SharePoint.PowerShell.SPWo...

My production system contains SPWopiBindings for both internal-https and also external-https. How can I get this system to have that?

I have tried deleting and recreating the wopi bindings. They are still internal-https. I tried creating them again and it says they already exist.

With this setting, no documents will open in office web apps, they always open in the client, even though the document library specifies to open in the client, and so does the server default, and the feature has been enabled.

2
  • what is your New-OfficeWebAppsFarm commands looks like, is it include the internal and external url along with certificate name?
    – Waqas Sarwar MVP
    Jan 5, 2017 at 13:51
  • it doesnt include the external url, only the internal, and it does include the certificate. i can test that the certificate works fine because i can navigate directly to the URL and see that it's using the certificate properly. I didnt specify the external url because prod doesnt have one and I am attempting to replicate prod.
    – Nacht
    Jan 5, 2017 at 23:58

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.