1

I have an on-premises installation of SharePoint 2013 on a development server, with a dedicated SQL Server instance on another server. Recently, my Central Administration site would stop loading and show a simple white screen.

Looking at the page source that comes back, I get the following:

<html><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=utf-8"><meta name="Robots" content="NOINDEX " /></head><body></body>
                <script type="text/javascript">
                 var gearPage = document.getElementById('GearPage');
                 if(null != gearPage)
                 {
                     gearPage.parentNode.removeChild(gearPage);
                     document.title = "Error";
                 }
                 </script>
                 </html>

I do not see any errors in the ULS or in the server event logs.

I have restarted both IIS and the SharePoint server. I have also successfully re-provisioned the Central Administration instance by using the following commands:

Unprovision: psconfig.exe -cmd adminvs unprovision

Provision: New-SPCentralAdministration -Port <your-port-num>

This post suggests that SharePoint be completely re-installed, but that's not an acceptable solution for me. Does anyone have any suggestions for this issue?

1

I would do following things to troubleshoot the issue.

  • Enable the IIS trace logging to get the actual error.
  • Turn Off the Custom Logging for the Central admin site.
  • Check the ULS logs and Event Logs for more clue.
  • Make Sure Default Web Site is stoped
  • Make Sure the Central admin App Pool and SharePoint timer service are running under the Farm admin account.
  • try to disable the loop back check on the server.
  • Run this command Get-SPWebApplication -IncludeCentralAdministration see if it return the Central admin. if Yes then try to use the url mentioned in it.
  • Thanks for the suggetions. I was always getting an HTTP 200 response when loading the site. It just woudn't return any content. Howerver, changing the web.config to debug="false" allows the site to load, albeit very slow. I'll keep digging, but thanks for your help! – Eric Paulsen Jan 5 '17 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.