2

I'm running SP2013 Enterprise and this is in my QA environment, not production. Recently my WFE became unresponsive. I removed it from the farm, ran get-SPproducts -local on the other servers (2 APP Servers, one of which is dedicated to SSRS) and then readded the WFE to the farm. This fixed the issue with the WFE not responding.

However the Health Analyzer started displaying "This Distributed Cache host may cause cache reliability problems." on the WFE. The AppFabric Caching Service is showing disabled in the services. When I run Get-CacheHost is shows as DOWN. The other 2 hosts are UP.

When I looked at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\AppFabric\V1.0\Configuration the ConnectionString and Provider values were empty so I looked at a healthy host and added those values in. I left the AdminConfigured and ServiceConfigured values set to 0, even though these were set to 1 on the healthy host, thinking this was set once the host was started up.

When I run 'Start-CacheHost –ComputerName WFE –CachePort 22233' it returns:

Start-CacheHost : Cannot start service AppFabricCachingService on computer'WFE.Company.Local'. At line:1 char:1 + Start-CacheHost -ComputerName WFE -CachePort 22233 + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : NotSpecified: (:) [Start-AFCacheHost], InvalidOperationException + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.ApplicationServer.Caching.Commands.StartAFCacheHostCommand

Add-SPDistributedCacheServiceInstance did not return an error howver the AppFabric Caching Service did not start up.

There is quite a bit of guidance out there on troubleshooting and getting a host set up, or restarted. Before I try anything else I thought I'd get some feedback and suggestions from folks here.

0

As you add this server back to farm, chances are permission may be missing.

Make Sure, Service Account which is running AppFabric Caching Service dont have the Log on as Service rights.

Please fix that and then re-analyze the rule.

If that do not work then try to remove the server from cache cluster then re add it.

 Remove-SPDistributedCacheServiceInstance

Then re add it

Add-SPDistributedCacheServiceInstance
  • I've verified that the service account has "log on as a service' rights to all sp servers in the farm. The HA rule persists. How critical is it that every server be a cache host? Can I just remove this server from the role and carry on? – Arale Dec 28 '16 at 15:41
  • Remove-SPDistributedCacheServiceInstance : cacheHostInfo is null Running Use-CacheCluster | Get-CacheHost did return info showing 2 hosts up and the WFE down. So WFE is part of cluster and AppFabric Caching Svc is disabled. – Arale Dec 28 '16 at 16:10
  • UPDATE: Removed WFE from cluster, used register-cachehost followed by set-cachehostconfig. Manually set the AF service to automatic. Executed Start-Cachehost. Result: STARTING. Timed out so I committed another taboo and manually started AF service. Service sat on starting for about 5 minutes. I ran get-cachehost: status UNKNOWN. I executed Unregister-cachehost, rebooted WFE & called it a night. The cachecluster is performing well so I should be able to build a new WFE but I'm learning and this is QA so I'll keep plugging away and take any advice offered as well as post my progress. – Arale Dec 31 '16 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.