1

I have basic setup(automatic mode) of incoming email setting in SharePoint 2013 box. I have setup a SMTP server in front end web server.

I see my sent email appear in the drop folder for a while and then disappear, I guess it is picked up by the timer job. However I didn't see the email in the doc library. The badmail folder also have nothing.

The ULS log have following entries:

12/22/2016 13:24:11.72 OWSTIMER.EXE (0x0E98)
0x1808 SharePoint Foundation Monitoring
nasq Medium Entering monitored scope (Timer Job job-email-delivery). Parent No 6515b0de-9156-473d-bd3c-917505d3cf27 12/22/2016 13:24:11.72 OWSTIMER.EXE (0x0E98)
0x1808 SharePoint Foundation Logging Correlation Data
xmnv Medium Name=Timer Job job-email-delivery 9772c39d-dd34-407d-b071-93b18f5cfee3 12/22/2016 13:24:11.72 OWSTIMER.EXE (0x0E98)
0x1808 SharePoint Foundation E-Mail
6871 Information The Incoming E-Mail service has completed a batch. The elapsed time was 00:00:00. The service processed 0 message(s) in total. 9772c39d-dd34-407d-b071-93b18f5cfee3 12/22/2016 13:24:11.72 OWSTIMER.EXE (0x0E98) 0x1808 SharePoint Foundation Monitoring b4ly Medium Leaving Monitored Scope (Timer Job job-email-delivery). Execution Time=2.1928 9772c39d-dd34-407d-b071-93b18f5cfee3

  • If the mail appears in Drop and then disappears, you're indeed correct when thinking the SMTP server is well-configured + the incoming email job picked it up. So, the problem may be with the address you configured with your doc lib – Evariste Dec 22 '16 at 6:58
  • Finally I solved the problem by switching the Incoming Email setting to Advance in CA, and specify the Drop folder. Don't know why the basic setting doesn't work. – Jason Chan Dec 23 '16 at 0:50
0

You should have a look at the Incoming E-Mail Settings in your DocumentLibrary. There are some settings which control the behavior of how the mail is saved. You can configure to only save E-Mail attachments and not the mail itself ("Save original e-mail").

Incoming E-Mail Settings of a DocumentLibrary

  • I solved the problem by switching the Incoming Email setting to Advance in CA, and specify the Drop folder. Thanks. – Jason Chan Dec 23 '16 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.