1

enter image description hereI have not configured UPS by PowerShell , but done via Farm Configuration wizard.

Added Mysite host URL in search content resource but only seven users who are testing the Sharepoint site added in the crawl.

But AD has more than a 1,00,000 users. How to connect with AD using User Profile Sync.

What are the details i need to enter from AD to sync?

  • 1
    You would have to set up a new connection, and my experience tells me it's best to start over. I would delete the User Profile Service Application and create a new one using the famous Harbar's guide on User Profile Service Application from scratch. Equally valid on SP2010, SP2013 and SP2016 harbar.net/articles/sp2010ups.aspx. Don't take any shortcuts - cause it will fail. – Benny Skogberg Dec 20 '16 at 13:46
2

From your question I guess that you mean that there is only seven MySites visible in search. It makes sense since the MySite isn't created until the user requests it. The first time a user tries to access MySite it's being created, but not before that. So if you have seven MySites from your testing users, things are working as expected.

  • That's good to know, but how can I sync rest of the users who are on AD, and that will help in showing relevant people result. – John Zachariah Dec 20 '16 at 13:19
  • @JohnZachariah Go to Central Administration > Manage Service Applications > User Profile Servie Application. You should see the total number of users who are synced to your environment there. If there are none, you may have to set up a new connection through "Configure Synchronization Connections". – Benny Skogberg Dec 20 '16 at 13:29
  • I see that only seven profile as told already, but I am looking at CA--> Manage Service Application--> UPS Application--> Configure Synchronization Connections --> I try to configure new to start syn between AD, I am left with no options, so clarifications needed here. – John Zachariah Dec 20 '16 at 13:41
  • 1
    Added the screenshot as well – John Zachariah Dec 20 '16 at 13:42
1

You have to create a Sync Connection between SharePoint UPA and AD.

  • For this from Central Admin > Manager Service Application, Click on the UPA.
  • On this Page Click on Configure Synchronization Connections
  • Click on the Create New Connection
  • Now you have to give the details of your AD, Service Account which will pull data from AD.
  • Once you done with connection then run Full sync.

Check this blog for more info. http://jaxsharepoint.blogspot.com/2013/08/setup-and-start-sharepoint-2013-user.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.