6

I got the following error while creating a new SharePoint web application on port 80:

Sorry, something went wrong Access to the path 'C:\inetpub\wwwroot\wss\VirtualDirectories\80' is denied.

creating a new SharePoint web application on others ports is working fine.

I am using farm account in SharePoint 2016

4

When you create a new Web Application you have to add host header name to your webapp. This means that your Web App with the host header name "portal" will have the path C:\inetpub\wwwroot\wss\VirtualDirectories\portal80, and another web app with host header name "test" will have the path C:\inetpub\wwwroot\wss\VirtualDirectories\test80. That way you can use more than one web app running on port 80 since they have different folders in IIS.

  • Thanks for your quick reply , i created a new one before with the same user without host header on port 80 that worked , but i delete it from CA , come back to create a new one again and got this error , the web application created but not browsed !! please help , – Aashirya Dec 19 '16 at 14:14
  • @Aashirya Both Web Apps need to have host headers. Delete and redo again, and it'll solve the problem. – Benny Skogberg Dec 19 '16 at 14:15
  • the same concept is needed for 2013 or it's only for 2016? – Aashirya Dec 19 '16 at 14:18
  • @Aashirya It works the same way for 2013 as 2016! – Benny Skogberg Dec 19 '16 at 14:19
  • additional question please , what about the web applications with other ports that worked without host header ! – Aashirya Dec 19 '16 at 14:20
2

Access denied means that their already web application created on that port. So you can't have two web application on single port without hostheaders.

  • delete the old web app created on port 80 and make sure no virtual directory exist after deleting on that path.now create new web app.
  • use the host headers( either FQDN or using host file entries) to create multiple web applications on port 80
  • or you can create web applications on different ports without host headers.
  • how to ensure " no virtual directory exist after deleting on that path" I select remove iis and content database !! – Aashirya Dec 19 '16 at 14:45
  • Go to that path and make it does not exist after deleting from central admin. What name for web application you are using? – Waqas Sarwar MVP Dec 19 '16 at 14:46
  • the name of web application is the server name , the path 80 exist after delete , please help – Aashirya Dec 19 '16 at 14:55
  • Can you delete that 80 folder? Backup the folder and paste it some other location then delete it on the path – Waqas Sarwar MVP Dec 19 '16 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.