1

I am using this codeplex code to develop advanced lookup. It mostly works fine till deployment. But when I tried to use it, on the list form it threw error in jquery file. Below is the error snapshot.enter image description here

Solution has two User Controls and one SVC service deployed in ISAPI folder.

  • Please Check if your search host controller service is working or not? If not then please do restart it from the Services.msc. – Dikesh Gandhi Dec 19 '16 at 11:47
  • I verified and "SharePoint Search Host Controller" Service is running – Mohit Dec 19 '16 at 12:08
  • Restart it and then try to deploy. – Dikesh Gandhi Dec 19 '16 at 12:10
  • You mean. should i uninstall and install WSP again? – Mohit Dec 19 '16 at 12:12
  • Restart the service. remove the solution from CA and install WSP – Dikesh Gandhi Dec 19 '16 at 12:13
0

Thanks to Robert's blog, I realized that Visual studio was not replacing token for my SVC file. So, i added below line of code in the .cproj file and it worked

<TokenReplacementFileExtensions>svc</TokenReplacementFileExtensions>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.