I've got a mixed environment with both AD users as well as FBA users. The FBA users are stored in a seperate ASP.NET membership database.

Now when I use search, both AD and FBA users show up. I'd like to limit those results to always only show AD users, the FBA users should be entirely excluded from search. Is there a way to tell the search engine not to index these folks?

I'm not importing any of the FBA users in profile import, since there is no import for non-AD users (as far as I know). Also, setting up crawl rules won't work because they only go for URL's and I have no clue what I would have to enter there to get it to ignore FBA users.

I did try limiting the people scope by adding an exclusion. But that requires a metadata property to check and I have no suitable property to use. The AccountName property contains the claims prefix (i:0#.w or i:0#.f) to indicate forms or Windows, but the scope rules only allow for an equals check, not for a contains or anykind of wildcard characters I believe?

  • Is this 2007 or 2010? My answer would differ. Sep 27, 2011 at 12:16
  • Ah sorry, 2010, I'll update my question
    – Jasper
    Sep 27, 2011 at 12:43

2 Answers 2


One way you could accomplish this is with the Crawl Rules on your Search Service Application in Central Admin. Look at the search results to see how the URL of the FBA users are displayed and then look at the URL of a normal domain user. Create a rule that will filter out the FBA URLs.

You can use wildcards and such to make it work. If you want to post the two URLs, we can help come up with the rule for you.

Be sure to select the "Excluded complex URLs" option when you create the rule.

  • Since I'm using the sps3:// webservices to query people results, I have no clue where I should get these URL's?
    – Jasper
    Sep 29, 2011 at 15:32
  • Do a search and filter base on the urls you get in the search results. Sep 29, 2011 at 16:43

In 2010 if you are using FBA with Claims you should be able to create a rule using the User Profile Property SPS-ClaimProviderType.

  • I tried adding a new managed property, but the Crawled Property selection window doesn't list that property. Is there something I should do to include it?
    – Jasper
    Sep 29, 2011 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.