3

In SharePoint 2013 farm, I can't start UPSS. When I try to start, it stuck on starting about 30 minutes and then it turns to stopped. On event viewer I found something like this.

The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (ID 28076c49-34cc-439e-bafc-17e4294682b5) threw an exception. More information is included below.

Unexpected exception in FeedCacheService.BulkLMTUpdate: Region not found..

Also Forefront Identity Manager services didn't running.

I did so many things but I couldn't fix it. Any suggestions?

Thanks in advance.


Update 19.12.2016

Updated SQL Server version to SP2 and now getting another error.

The Execute method of job definition Microsoft.Office.Server.UserProfiles.UserProfileImportJob (ID 1f0ab8b2-be0c-4ccd-a7c8-850d40797ef5) threw an exception. More information is included below.

Operation is not valid due to the current state of the object.
5

The behavior of UPSS starting then stopped has more reasons, so you should make sure that:

  • You are using the Farm Account to start UPSs.
  • The Farm account is added to local administrator group during starting UPS service.
  • Adding the service account running User Profile Sync Service to local administrator group on the server running Distributed Cache.
  • AppFabricCachingService in services is running via Farm account.

Note:

  • After adding the farm account to local administrator group, you must restart the SharePoint 2013 Timer service.
  • Adding farm account to local administrator group is required only to start the User Profile Synchronization service. After the User Profile Synchronization service is started, you can remove the farm account from the Administrators group. for more details check.

  • If you use SQL 2014 check: SharePoint 2013: Unable to Start the User Profile Synchronization Service

For more details check User Profile Synchronization Service Starting then Stopped in SharePoint

  • 1
    Thank you for your answer. We are using SQL Server 2014 RTM and will ask DB admins to update SQL Server version. I will edit this after updating SQL Server version. – newbie Dec 19 '16 at 6:12
  • Hope it solve your issue, please update us with the result – Mohamed El-Qassas MVP Dec 19 '16 at 6:48
  • Updated SQL Server version; but getting another critical error. Updated question. – newbie Dec 19 '16 at 8:39
  • Thank you so much for your help. I've finally solved my problem. I will add steps as an answer because of length of steps. – newbie Dec 20 '16 at 11:41
  • Glad to hear that your issue has been solved , so if the steps above helped you to solve your issue please upvote it and set it as answer , thanks – Mohamed El-Qassas MVP Dec 20 '16 at 11:43
1

Is the Distributed Cache service running? I did a simple search and came up with

https://social.technet.microsoft.com/Forums/office/en-US/7abab9b1-8415-48f2-b211-51f2bfe1d095/sharepoint-2013-so-many-6398-errors?forum=sharepointgeneral

It has some reflected code in it that may lead you in the proper direction to a solution.

  • Thank you for your answer. Distributed Cache service is running but still UPSS is stopped. – newbie Dec 19 '16 at 6:14
1

Finally I've solved my problem. It's about SharePoint 2013 and SQL Server 2014. Applied this in test farm and it works fine.

Followed these steps:

  • Updated SQL Server 2014 RTM to SQL Server 2014 SP2
  • Installed SharePoint 2013 April 2014 CU ( can be found here )
  • Ran SharePoint 2013 Products Configuration Wizard
  • Got a problem on SharePoint 2013 Products Configuration Wizard and solved using following PowerShell script ( this script and all other steps can be found here )

    PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures 
    

After all of these, UPSS started successfully.

0

One of the definitive guides I use for configuring UPS is Spencer Harbar's post here:

http://www.harbar.net/articles/sp2010ups.aspx

It's for 2010, but the steps are identical.

  • Thank you. I checked Harbar's blog but I couldn't solve. – newbie Dec 19 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.