3

I have a list with a name, email field, and position field.

The odd thing is when I call the value of the lookup in a workflow email, a 6;# is appended to the front of all three fields.

There are no empty spaces. How do I correct this, please?

3
  • Try to create a workflow variable with data type string.
  • Set the value of the variable to Current Item , select the look up return field value as Lookup value with comma

enter image description here

  • Use the new variable in your email as the following

enter image description here

  • M.Qassas < You're amazing. Thank you!!!!! ( Yet again. :) ) – Mike Rooker Dec 16 '16 at 5:07
  • :( when I created the variable as shown in the first box, I get "lookup for string" NOT "lookup for Person or group" and only see return field as : "as string" and "lookup value for text". And in all I still get a # in front of the value. I have spent hours.. What am I doing wrong please? – Mike Rooker Dec 16 '16 at 23:20
  • don't worry, let's trace your steps, should you tell me what's your lookup field settings in list settings – Mohamed El-Qassas MVP Dec 16 '16 at 23:31
  • also what's the SharePoint platform that you are using it's workflow 2010 / 2013 – Mohamed El-Qassas MVP Dec 16 '16 at 23:35
  • I have a column named Approver.It is a lookup field to a list with names on one column ,email on another and job title on the third. I created a local variable called "approverEmail" as a string. I set the aforementioned to the currentitem:Approvers:email value.( from the lookup column) In the email workflow "Participants"> Workflow Lookup for a User> I selected Data Source : workflow Variables and Parameters. Field from Source Variable: approverEmail. Return Field As: Email Addresses, Semicolon Delimited – Mike Rooker Dec 17 '16 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.