I have a custom sharepoint list that we are inputting data into. (SharePoint 2013.) This is a fresh list and was not migrated over from any other version of SharePoint.

Everything can be edited through Quick Edit, except for columns that have checkboxes. I have attempted to quick edit through a Standard View, and a Datasheet View. I can edit any other type of column, but when I try to edit the checkbox, that cell gets greyed out.

I checked the view, and the "Allow individual item checkboxes" is selected under Tabular View.

There is no Groupings under Group By.

Style is set to "Default". I tried switching to a different style, saving, and switching back to "Default" and saving. No dice.

Everything else is set to defaults as far as I can see.

There are no workflows for this list.

Why am I unable to edit checkbox columns in Quick Edit mode in Standard view, or with a Datasheet view?

EDIT: With further testing, I see that a checkbox cell becomes read-only if you enable Allow 'Fill-in' choices for that multi-choice column. Pretty funky. Is there anyway around quick editing a checkbox column that allows Fill-in options? I would rather not have to open up every single item in order to edit that column.

1 Answer 1


It's by design, In Quick Edit, unfortunately, you can't Allow 'Fill-in' choices with Checkboxes (allow multiple selections)

enter image description here

There is no explicit workaround to do this, but in bulk edit, you should choose between the following options

  • Checkboxes (allow multiple selections) without Allow 'Fill-in' choices, or
  • Drop-Down Menu with Allow 'Fill-in' choices.
  • Weird, as on a separate 2010 SharePoint server we are able to edit checkboxes with fill-ins. Oh, Microsoft! Dec 16, 2016 at 16:11
  • 1
    you are welcome, please set it as an answer if it helped you, it's the true sign beside my answer also check this to get informed badge sharepoint.stackexchange.com/tour Dec 16, 2016 at 18:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.