Get-SPO365LinkSettings failed, make sure you have permission for User Profile Service Application

Can't get around this message during SharePoint Hybrid Configuration Wizard for SharePoint 2016 onPrem & O365.

I've already added the user as Admin in Central Administration -> User Profile Service Application.

Also checked this post The PowerShell command for SPO365LinkSettings does not exist in the SharePoint farm) where it is suggested to add the pages to trusted sites.

UPDATE 1: Tested the Get-SPO365LinkSettings Script and the output is:

Get-SPO365LinkSettings : Found 2 site subscriptions for managing hybrid settings. Expected a single tenant.

UPDATE 2: Further investigated the double site subscription with Powershell


And there are 2. The first with the normal domain and the second with a sitemaster SPSite Url. Should I delete the sitemaster subscription?

  • Looks like you've tried to connect to another tenant with the same OnPrem farm. You need to remove "the other tenant" somehow, which I'm nut sure how to do. Maybe start checking your accounts in you local Active Directory and see if you find any external references there?
    – Benny Skogberg
    Dec 13, 2016 at 19:35
  • 1
    checked the accounts, no chance. I've opened a MS support case, currently doing the ping pong from onprem support to cloud. It seems the onprem support is responsible cause of the Powershell message "Found 2 site subscriptions for managing hybrid settings. Expected a single tenant."
    – djHonda
    Jan 3, 2017 at 12:46

1 Answer 1


I've deleted the second site subscription settings (from sitemaster), have a look at this article from MS

The wizard runs now smooth without error and the tiles from OneDrive and WebSites are redirecting now to O365

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.