0

I created a simply custom workflow that up until recently had the approve and reject buttons on edit task form. Now I have a approve or reject drop down. How do I get the buttons back?

enter image description here

2

As per my understanding, Your task is created of "Task" content type.

You will need to add "Workflow Task(2013)" content type in your task list and then create task of "Workflow Task(2013)" content type.

So it will automatically give you Approve- Reject buttons.

Please refer this link.

1

Please make sure that following features are not deactivated by mistake:

  1. Site collection features > SharePoint Server Publishing Infrastructure

  2. Manage Site Collection features > Publishing Approval workflow feature

0

You should have Task outcome as the last column in the column order to get the outcome as buttons

To do that, you need to goto

List settings-> click on the content type name(workflow task 2013) -> click on column order -> Make the task outcome as last column and click ok

enter image description here

Now if you refresh your task edit page, you should be able to see the Approve/Reject as buttons

0

In addition to having the 'Task Outcome' as the last column in the Content Type, you will have to ensure 'Task Status', '% Complete' and 'Priority' are not hidden.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.