1

"All Files" has suddenly stopped working in my SharePoint Designer 2013. It doesn't even try to load files. I just says "There are no files in this view that match the current filter settings...". Clicking Masterpages will show all masterpages as expected. Clicking back to "All Files" does nothing. Clicking the refresh button does nothing.

I am an Office 365 Global Admin. I am the Site Collection Admin. This is true for all Site Collections on my Tenant. It worked fine for 3 years and just stopped this week. I have rebooted. I have completely uninstalled SharePoint Designer. I have reinstalled this time to 64 bit. I have installed the Service Pack 1. Clicking all other items works fine, it's only All Files that is broken I am assuming there is some sort of cached setting or registry setting as the problem persisted after a complete uninstall/reinstall.

Somebody must know. Please help!

5
  • Does this happen for all document libraries or just one in particular? Are you over 5000 items in your library? Dec 12, 2016 at 14:43
  • Its the "All Files" link in SharePoint Designer for the Site and its all sites in all Site Collections. Dec 12, 2016 at 17:03
  • Have you tried hitting F5? That usually refreshes the view for me. Dec 14, 2016 at 16:12
  • Yes I tried hitting F5 first. When that didn't work, I clicked the refresh button in the ribbon, then tried the refresh button in the top right of the right pane. Then I tried the usual, click any other item in the left nav then back to All Files (this normally fixes the issue). When none of that worked I right clicked on All Files and hit the "Pin" option. This loaded all the files in Left nav and allowed me to continue to work, however I've never been able to get the right pane to show all files again. Crazy. Dec 16, 2016 at 15:09
  • I'm having this issue on SharePoint 2013 64 bit Designer, tried all the above options, it does not work. Jun 5, 2017 at 16:37

3 Answers 3

3

I had this issue for a while and could not figure out what was going on.

Then, I realized it is actually filtered!

After you select 'All Files', go to every column and click on its name. Make sure every column's name's drop down is set to 'All' instead of custom.

One of my columns (Modified By) was set to filter, which is why it wasn't showing anything for me.

The actual bug is that Designer does not have great UI feedback. It does not display a column's filter directly to you, which is kind of silly. It collapses it after you choose a filter, and you think there are no filters set!

2
  • Thank you from the year 2021!
    – JimShelley
    Jul 19, 2021 at 15:54
  • Thanks It help me out..... Aug 26, 2021 at 9:06
1

This happens very often with me too, I've found a workaround to this. Click on any other option in left navigation for e.g. Subsites or Site Assets, and then click back on All files again. This seems to work.

Click on Subsites

1
  • That was my go to move until last week when that stopped working for me :( Dec 12, 2016 at 15:18
1

While none of the usual fixes worked for me, I was able to get a partial fix by "Pinning" the "All Files" link. This immediately loaded "All Files" in the left navigation and allowed me to navigate down to my content search templates and complete my work. My right pane is still broken for All Files, but at this point I don't really care as I'm able to complete my work by navigating in the left nav. Interesting that this ONLY works if I pin the All Files in left nav.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.