0

We were unable to open a given document library/folder in Explorer View due to the "A device attached to the system is not functioning". Because it had 10K files in it, we had to make the registry change outlined in KB article 912512. Once we did that (set it to value 1,000,000,000), we were then able to open the folder in explorer view and UNC path, but only if we were logged onto the sharepoint server locally. From any other browser on a client laptop/server, we got the "A device attached to the system is not functioning". We restarted the services, rebooted the VM, still we cannot get explorer view unless we are logged into the sharepoint server locally.

We have another document library/folder with just under 4K files, and we can access that one just fine locally and remotely, even via UNC we can access it.

This is SharePoint 2010 on Windows Server 2008.

Any ideas?

  • have you tried with FQDN or with IP address. – kesava Dec 5 '16 at 22:07
  • I get access denied with both of those. – Greg Dec 5 '16 at 22:47
  • 1
    I'm such an idiot. The registry change has to be done on every client machine, not just the server. lol – Greg Dec 5 '16 at 23:03
2

The fix is to apply the registry change to the client. I was only applying it to the server, thinking it would propagate to all the users.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.