3

Getting error when clicking on Content and Structure log.

Also getting same error on below one.

In Edit mode of page, when i trying to add link, I am getting following error.

enter image description here

enter image description here

Things I tried,

1) checked log for generated correlation id, nothing found.

2) checked event log and getting error related "App state update".

Any kind of help will be appreciated.

  • there must be something with the co realtion id. At what point it throws error... please check that. clear cache and edit in new window. and check in developer tool in Network tab if any where anything is logged – Ankit Kumar Dec 5 '16 at 14:31
  • did you try to choose second option, From address? If it doesn't give you an error, insert SharePoint link in and you are good. – Danilo Dec 5 '16 at 14:34
  • @AnkitKumar I have searched correlation id in sharepoint log, but nothing found related. And there no error coming on console also. – Anil Pal Dec 6 '16 at 7:12
  • @DaniloKorac, 2nd option , From address is working – Anil Pal Dec 6 '16 at 7:13
  • Even also Content and Structure log is also not working, giving same error – Anil Pal Dec 6 '16 at 7:14
3

Finally solved.

Filtered log message with list and failed and checked for below kind of error,

[STS3::COWSList::GetList] Initialize failed. Return error to caller, URL = sts4://url/siteurl=/siteid={b0485081-a7c0-4029-8009-9c2c38513815}/weburl=/webid={123f3c8c-5a2a-42e9-acbd-bfb67b8084f7}/listid={b4c8bf79-183e-450d-8308-43550697ab51} hr=80642616 [sts3util.cxx:5723] search\native\gather\protocols\sts3\sts3util.cxx

After that i verified given list id i.e

b4c8bf79-183e-450d-8308-43550697ab51

from application and found out that library setting page of that list was failed to open and throw error.

Finally I came on conclusion that this list has been corrupted and need to delete and recreate again.

After deleting, everything started working. Hurray :-)

  • There is always something in co-relation id. Good job!! – Ankit Kumar Dec 6 '16 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.