3

I have created basic SharePoint 2016 Empty Project farm solution in which I have just created one custom list. When I am deploying the solution, got the error:

Unable to load one or more requested types. Retrieve the LoaderExceptions property for more information.

Even in empty solution without any list, webpart or anything in the solution got the same error. I am using Visual Studio 2015 Community edition.

  • Which target frameworks are you using for? Please also check SharePoint dll references. – Dikesh Gandhi Dec 6 '16 at 9:00
  • 4.5 All dll added to project. – Ronak Patel Dec 6 '16 at 9:15
  • Have you tried to clear my AppData/Local or to repair Visual studio setup from uninstall a program? – Dikesh Gandhi Dec 6 '16 at 9:28
  • yes...... did it but not working – Ronak Patel Dec 6 '16 at 9:52
2

Resolved the issue with:

  • Uninstall the Visual Studio 2015 Community.
  • Cleared the AppData/Local.
  • Install the Visual Studio 2015 Professional.
  • Now able to deploy without any error.

Not sure that it was the issue of Community Edition or anything else but this resolved the issue.

  • I don't believe Community Edition supports SharePoint Server. (I didn't think Pro did either as the SharePoint parts of MSDN are only in the Enterprise SKU) – Greg W Mar 7 '17 at 10:25
  • which folder in "AppData/Local" ? – codemirror Jan 23 '18 at 10:54
0

Need to install SharePoint Server 2013 Client Components or SharePoint Server 2016 Client Components to solve this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.