0

I have created a web application which is hosted on port 80, I was not able to open it initially, in IIS I saw that the website was stopped and when i tried starting it, it prompted the following error. The default webiste was using the port 80 so I had to stop the default website and then start my custom website.

Is there any solution to this, why cant I start more than one website on the same port.

Is it something to do with the application pools. enter image description here

2

Short answer: Default Web Site is included everytime the IIS feature is enabled on a server, so you don't need it. Simple stop it and then go on with your new web application using port 80.

While creating a DNS entry for a web application, you create the entry for the servers IP adress and port.

As an example, imagine that you have created two webapplications (intranet.example.com and contoso.example.com) using the same port and created a DNS entry for both of them. (Both will have the same IP and port.)

Now if you would try to access any of them using the adress assigned, IIS won't simply know to which web application your request should be sent to because both of the web applications uses the same IP and port.

If you would like to use multiple webapplication on the same port, use HostHeaders.

Configure a Host Header for a Web Site

0

First of All, you should stop the Default Site, it is not good for SharePoint.

You have two options in this case:

You can create Multiple Web Application on the port 80 but you need the different host header.

Or you can create the Web Application on different port, like one with on port 80 and 2nd on the port 82 and so on.

Check this article:Creating Multiple SharePoint 2010/2013 Web Applications in Single Port

0

When request comes to IIS, IIS tries to resolve web site which is responsible for this request based on combination of different params.

This params are ip address, port number and host header. Each web site should has unique combination of mentioned params.

In your case SharePoint web application on port 80 using combination ip:port (I'm guessing you didn't provide host header). Default IIS web site also uses this combination, that's why it's not possible to run it and you see this error.

If you want to run multiple web sites on the same port in IIS, you need to add unique host-headers under web sites bindings:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.