0

I made a sharepoint winform application(reference Microsoft.SharePoint.dll version 12.0)

I registered that dll using gacutil.

But In my PC, SharePoint 2016 is installed, So in Visual studio, build and run is okay.

When I try to run some button event, exception occured like this

Could not load file or assembly 'Microsoft.SharePoint.Library, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The system cannot find the file specified.

So I think the problem is the different dll between my PC SharePoint(version 16)

and Application`s SharePoint(version 12). Is that right?

If that is right, is it impossible to run in my PC?

Please somebody help me

0

you have to extract the dll's from the server where 2007 version of SharePoint is installed and refer that in your application. deploy the same in the gac as well.

I did the similar way where the installed software is wss 3.0 but referring older version of sharepoint 2001/wss 2.0 for some migration purposes.

This will work without any issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.