0

I am in the middle of my SharePoint 2013 installation, after installing all the pre requisites I am getting an error with .Net framework stating that the installation requires .Net framework 4.5 and the log file states that I need to have .Net Framework version 4.5.50501

I do have .Net framework 4.5 installed on my machine and the current version is showing as 4.6 when I check in regedit.

I am unable to install .Net fw as it states that a higher version already exists.

How do I go about and fix this. enter image description here

enter image description here

0

This is a known bug if you already have .NET framework 4.6 installed before installing SP 2013.

During the installation the installer verifies if .NET framework 4.5 is available and fails to install SharePoint 2013 if .NET framework 4.6 is installed.

The reason is that .NET framework 4.6 replaces .NET framework 4.5 and is not a side-by-side installation. As the installer is not able to match .NET framework 4.6 to .NET framework 4.5 it will prevent the installation.

Microsoft released a fix for this here.

  • I changed the the version number in the binaries and that kind of solved the issue, picked up from an article on technet, this was a dev environment so its okey to do so, but yes as you said in production the above mentioned article would be of help. – CodeAbaddon Dec 2 '16 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.