0

I am trying to configure AAM(Alternate Access Mappings) on a environment with an HLB(Hardware Load balancer) configured.The DNS name of the site, say, "myspsites.com" is pointing to the HLB and this routes requests to wfe1, wfe2 and wfe3.

What should AAM configuration look like? I expect it to work if I only put http://myspsites.com as the default URL but it doesn't.

I should note that there are 4 web applications on this farm, all is being served from port 80 (there are additional bindings added on these IIS Sites, for example the one I am trying to configure have 8081 http binding added on IIS. I am worried that this IIS configuration is done in an improper way, so SharePoint is unaware of those settings. I am not an expert on IIS but I know that SharePoint should be configured to respond via AAM settings, not on individual IIS Web Site settings.

Can someone please provide me some advice, on how to get AAM properly set up in this environment?

  • on which port HLB is forwarding the traffic, port 80 or 8081? also are you using different host headers in the IIS for each web app? – Waqas Sarwar MVP Nov 30 '16 at 21:53
  • HLB is on port 80 – ova Dec 4 '16 at 20:02
  • hmm I am only interested one of the web apps so didn't check the other ones but will check tomorrow morning – ova Dec 4 '16 at 20:03
0

Couple of things to check

  • Check under which port HLB forwarding the por, 80 or 8081? if 80 then you have to update the IIS with correct port and enter the host header of you url
    • In AAM settings of the SharePoint, you should have the http//mysite.com in the default zone.
  • If it is forwarding to the 8081 then you internal url will be with 8081 and public will be http://mysites.com
  • also try to directly hit the server with port numbers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.