2

When I add &IsDlg=1&InitialTabID=Ribbon.Browse to the Dispform.aspx url, I only see the column names and content. The &IsDlg=1 removes the navigation etc. and &InitialTabID=Ribbon.Read removes the Ribbon. That is exactly what I want. So far, so good...

But, when I add the exact same url to a Page Viewer Web Part, the navigation etc. is still removed, but the Ribbon is still there (in the Page Viewer Web Part). I don't understand why. Could anyone explain this behaviour, and even better - let me know how I get rid of the Ribbon in the Page Viewer web part in an easy way?

  • I have tried directly in sharepoint URL with &IsDlg=1&InitialTabID=Ribbon.Read ,.but not working .. ribbon is still there .. – Ronak Patel Nov 30 '16 at 12:35
  • My fault, it's a typo. The correct url should be DispForm.aspx?ID=1&IsDlg=1&InitialTabID=Ribbon.Browse – Jenny Fergéus Nov 30 '16 at 13:29
  • @JennyFergéus: it doesn't work for me too, either Ribbon.Browse or Ribbon.Read – Sergei Sergeev Nov 30 '16 at 14:18
  • @Kai, but did you get it to work in the dispform.aspx? Because it works perfectly there for me. I just can't figure out why it won't work in the Page Viewer WP in the default.aspx page. Really frustrating! – Jenny Fergéus Nov 30 '16 at 14:33
  • It doesn't work for me on dispform, ribbon is always visible no matter which query string I'm using – Sergei Sergeev Nov 30 '16 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.