0

When editing (already existing) pages users are getting an unexpected error which in logs shows that the file:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Resources\filename.en-US.resx

Cannot be found. The only file we have on our servers however is:

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Resources\filename.resx

We don't appear to have any localised version of these files. And the issue isn't happening on newly made sites.

I read somewhere web parts were having issues with the KB284486 patch.

Does anyone have any ideas?

  • Is it sub site where you get file not found exception? – Viraj Gorajia Nov 30 '16 at 11:04
  • @VirajGorajia It's happening on all sites/subsites that were made. New sites don't seem to have the issue. – Linty Nov 30 '16 at 11:32
1

Try this:

If possible try putting the resource files in `

C:\inetpub\wwwroot\wss\VirtualDirectories(SharePoint Site)Port\App_GlobalResources

`

(SharePoint site)Port should be the virtual directory where you are deploying to solution

Try following commands with command prompt

cd /d "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\Resources"

copy filename.resx filename.en-US.resx

  • Resource files are already in that location. I just need to update the existing sites resource files so that it points to filename.resx instead of filename.en-US.resx – Linty Nov 30 '16 at 11:54
  • Have you added file in 14 hive? – Viraj Gorajia Nov 30 '16 at 11:56
  • Yes it's already there. – Linty Nov 30 '16 at 11:56
  • Have you checked the name of file? – Viraj Gorajia Nov 30 '16 at 11:57
  • The file hasn't been changed, its a custom file that we made and had been working fine until now. It's looking for a localized version of the file. – Linty Nov 30 '16 at 11:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.