3

I have configured User Profile service in my environment. It was working fine till we shift our database to other server.

Currently we are not able to get sync profiles. It shows blank. Refer below screenshot for same:

enter image description here

When I checked in the Manage user profiles, it shows me below error:

Your search encountered an error. If the problem persists, contact the portal site administrator.

I search for this and found below solution:

  • Check "ForeFront Identity Manager Service". which is running. I have restarted UPS to check its running state. And its working fine.
  • Created new User Profile service. Might old profile refer to old db. So we trie creating new UPS. but still we have same issue.

One more thing, we do not have search service in our farm. Do we need search service for user profile sync? Anything else which I need to check to fix this issue?

  • Do you face any error when start to sync user profile? – Viraj Gorajia Nov 30 '16 at 11:10
  • Have you change database server name in property of User Profile service application? – Viraj Gorajia Nov 30 '16 at 11:15
1

I've encountered the same issue. In my case when I open the User Profiles management page (which is on your screenshot) I'm getting the following error in ULS:

UserProfileServiceUserStatisticsWebPart:LoadControl failed, Exception: Microsoft.SharePoint.SPException: The trial period for this product has expired.

Which describes the reason of that behavior.

  • This should be the accepted answer. Had the same issue and an unregistered SharePoint Server was causing the described issue. – Ben Lime Jan 30 '18 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.