0

I have a SharePoint list. People can fill the form and submit that form to the list. I created a calculated column with the code below. This code générated a link in the list. Once people click on the link generated , it should open the form filled in Read Only mode. But actually, it is not the case. I would like to know how can I force the form to open in ReadOnly mode once users click on the link. Here's the code: ---

="<a target='_blank'  href=https://MyWebSite.MyDomain.com/SiteName/_layouts/Print.FormServer.aspx?XmlLocation=/cours/MyList/ItemNum%20no%20"&RequestNumber&".xml&ClientInstalled=false&Source=http%3A%2F%2FMyWebSite%2EMyDomain%2Ecom%2FMySiteName%2FMyList%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1><DisplayRequest</a>"
  • Hi @djqibbs are you using infopath ? – Mohamed El-Qassas MVP Nov 28 '16 at 18:04
  • Hi M. Qassas yes i am using InfoPath – djgibbs Nov 28 '16 at 18:06
1

There is not any option that will let you open InfoPath form as read-only directly ,

But you can achieve this by

  • Designing a read-only view and
  • Set the URL to point to this view by adding &DefaultView=yourviewname to your Link.

To do this follow the mentioned steps below :

  • On the View menu, click Manage Views.

  • Under Actions, click Add a New View.

  • In the Add View dialog box, type a name for the view, and then click OK.

  • Design the view by adding layout tables and controls to it.

TIP: If you want to base the design of a new view on an existing view, open the existing view, press CTRL+A to select everything in the view, and then press CTRL+C to copy the selection to the Clipboard. In the Views task pane, switch to the new view, and then press CTRL+V to paste the selection in the new view. At this point, you can delete any controls or layout elements that you don't need from the new view.

  • In the Views task pane, click View Properties.

  • Click the General tab.

  • Under View settings, select the Read-only check box, and then click OK.

For more details check Design a read-only view

Then in your URL specify &DefaultView=yourviewname to your link before or after&DefaultItemOpen=1

  • 1
    Thankyou a lot Qassas. It works. – djgibbs Nov 28 '16 at 19:30
  • Glad to hear it's helped you, could you please upvote it :) – Mohamed El-Qassas MVP Nov 28 '16 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.