1

I extended the sharepoint 2013 site (http://sharepoint.mydomain.com) to https(on port 443) (https://sharepointdifferent.mydomain.com) with SSL enablement. Created the self signed server certificate from IIS and imported the same certificate in trusted root certification authorities and binded the same certificate for the extended site in IIS Manager under "Bindings". But on accessing the extended site I am getting the error

An operation failed because the following certificate has validation errors: Subject Name: CN=XXXXXXXXXXXXXX.XXXX.net (server details) Issuer Name: CN=XXXXXXXXXXXXXX.XXXX.net (server details) Thumbprint: XXXXXXXXXXXXXXXX...... Errors: SSL policy errors have been encountered. Error code '0x2

Please help.

1

Try to disable certificate checking in web.config of the extended SharePoint application as the following :

  • Locate the extended SharePoint web application.
  • Take a backup from its web.config.
  • Edit web.config.
  • Try to add servicePointManager tag inside system.net tag as the following :

Web.config

<settings>
<servicePointManager
 checkCertificateName="false"
 checkCertificateRevocationList="false"
/>
</settings>

Also, you can check more details / other solutions at An operation failed because the following certificate has validation errors

0

The server is registered in SharePoint with its short name and this certificate subject contains the FQDN name.

Now Solution is

  • Get another certificate with a matching subject name( i would add both FQDN and Short name of the server in Subject Alternate)

SharePoint – event 8311 – SSL policy errors have been encountered. Error code 0x2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.