I have a site collection that is listed in Central Admin > Application Management > Site Collection list. When I click on the link there, no details are shown on the right hand side. The site collection was clearly deleted some time ago, but it seems the process didn't complete properly, and references to it still exist.

Using PowerShell I have established that this site collection is associated with a Content Database and obtained the GUID of the site collection.

ApplicationRightsMask      : FullMask
ID                         : af9f1d5f-4fdd-4cc0-a1e8-c42969c3f4ef
SystemAccount              : 
Owner                      : 
SecondaryContact           : 
GlobalPermMask             : FullMask
IISAllowsAnonymous         : False
Protocol                   : http:
HostHeaderIsSiteName       : False
HostName                   : division
Port                       : 80
ServerRelativeUrl          : /site/fim/BDSU
UpgradeRedirectUri         : 
Zone                       : Default
Url                        : http://division/site/fim/BDSU
Impersonating              : False
Audit                      : Microsoft.SharePoint.SPAudit
AllWebs                    : 
Features                   : {}
PortalUrl                  : 
PortalName                 : 
LastContentModifiedDate    : 
LastSecurityModifiedDate   : 
CatchAccessDeniedException : False
AllowUnsafeUpdates         : True
UserToken                  : Microsoft.SharePoint.SPUserToken
IsPaired                   : False
SearchServiceInstance      : 
WebApplication             : SPWebApplication Name=Division team sites Parent=SPWebService
ContentDatabase            : SPContentDatabase Name=wss_fin2_isd Parent=SPDatabaseServiceInstance
Quota                      : 
RootWeb                    : 
LockIssue                  : 
Usage                      : 
ReadLocked                 : 
WriteLocked                : 
ReadOnly                   : 
WarningNotificationSent    : 
UserAccountDirectoryPath   : 
SyndicationEnabled         : 
AllowRssFeeds              : 
CertificationDate          : 
DeadWebNotificationCount   : 
RecycleBin                 : 
ExternalBinaryIds          : {}
CurrentChangeToken         : 1;1;af9f1d5f-4fdd-4cc0-a1e8-c42969c3f4ef;634523580105300000;59055
WorkflowManager            : Microsoft.SharePoint.Workflow.SPWorkflowManager 

However, when I do stsadm -o enumallwebs -database wss_fin2_isd I do not see the site listed at all.

When I try and delete the site using stsadm -o deletesite -url http://division/site/fim/BDSU -force -siteid af9f1d5f-4fdd-4cc0-a1e8-c42969c3f4ef -databasename wss_fin2_isd -databaseserver vsqlsp I get a message saying I have to specify the URL or ID of the site collection which I clearly have.

stsadm -o databaserepair -url http://division/site/fim/BSDU -databasename wss_fin2_isd I get the message <OrphanedObjects Count="0" />

I have also tried disconnecting and reconnecting the content database, but that has not removed the site collection.

I also tried deleting the site collection through powershell $sitecollection.Sites.Delete("http://division/site/fim/BDSU") - no output is returned.

If I try to create the site through powershell I get the following output:

>$sitecollection.sites.add("http://division/site/fim/BDSU","admin","[email protected]")
Exception calling "Add" with "3" argument(s): "Another site already exists at
http://division/site/fim/BDSU. Delete this site before attempting to create a new site 

with the same URL, choose a new URL, or create a new inclusion at the path you originally specified."

Anyone have any ideas about what else I can do to remove this site collection completely? I get a lot of errors relating to it, I think from Timer jobs that are picking up the reference to it from somewhere, but not sure where.

  • I'm having the same problem any help will be appreciated
    – user6203
    Dec 29, 2011 at 23:22
  • I have exactly the same problem. Anybody find a way to remove this type of orphan? Thank you, Mario
    – user9036
    Jun 22, 2012 at 13:01
  • Was there every a solution to this problem? We have exactly the same problem here. I can find it in PS but I can't delete it with PS, STSADM nor CA
    – user11089
    Oct 2, 2012 at 17:34

3 Answers 3


You may want to check references to it in your configuration database, I've often found references to databases there that show up in Central Admin that no longer exist. Or if you don't have anything else installed, and don't mind the time, then reinstall and get rid of the databases - unfortunately that was my solution once or twice before.

  • Yes - I can see that the site collection is refered to in the SiteMap table for the config database, even if it is no longer in the content database.
    – dunxd
    Sep 23, 2011 at 15:22
  • 1
    Look in the Objects table, in the Name field you can often find references to older databases that were not completely removed. Although if you have to do this, I'd suggest you rerun the configuration because at this stage you're way outside normal operating parameters.
    – MichaelF
    Sep 23, 2011 at 15:22

Have you tried browsing to: http://division/site/fim/BSDU/_layouts/deleteweb.aspx and seeing if that page loads up? If so, trying deleting it there. Or you can also try deleting it from central admin since it seems to be showing up in central admin.

  • This throws a file not found error. The site really doesn't exist any more. There is just some reference to it lurking around.
    – dunxd
    Sep 23, 2011 at 12:14
  • Ok, what about using the delete site collection in central admin? Sep 23, 2011 at 12:17
  • It isn't possible to select the site collection in this - the selection option takes me to the site collection list, and I can find /site/fim/BDSU in there, but when I click on Ok, I am returned to the Delete Site Collection page with no site collection selected.
    – dunxd
    Sep 23, 2011 at 14:41
  • 1
    Interesting, I also found this page: technet.microsoft.com/en-us/library/cc288016(v=office.12).aspx According to it you shouldn't be specifing the URL in the syntax: stsadm -o deletesite -force -siteid e2a114b8-80c9-41f6-87bf-3feddf2ad9b6 -databaseserver DS1 -databasename DB1 Sep 23, 2011 at 14:58
  • Ok- that gave a different error message, but didn't fix it: There is no site collection with Id = af9f1d5f-4fdd-4cc0-a1e8-c42969c3f4ef in content database wss_fin2_isd on database server vsqlsp. Gah!
    – dunxd
    Sep 23, 2011 at 15:11

Kind of a bit old, but now I'm putting an end to a 2007 farm got accross this. How I got to do it is quite close to what you did, though notice you wrote -0while actually you meant -o. Also the url is not needed, just the site collection id:

stsadm -o deletesite -force -siteid af9f1d5f-4fdd-4cc0-a1e8-c42969c3f4ef -databasename wss_fin2_isd -databaseserver vsqlsp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.