2

All my workflows in a SharePoint server stopped working.

I see this when trying to viewing workflows for an item:

Some workflows may not be shown. We were unable to reach the workflow service.

Here is the error JSON returned from the server when I try to run a workflow manually from the browser:

[
{
"SchemaVersion":"15.0.0.0","LibraryVersion":"15.0.4763.1000","ErrorInfo":{
"ErrorMessage":"The underlying connection was closed: Could not establish trust relationship for the SSL\u002fTLS secure channel.","ErrorValue":null,"TraceCorrelationId":"597cba9d-1b29-00d8-13d9-1856016bf83c","ErrorStackTrace":"   at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)\r\n   at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)\r\n   at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)\r\n   at Microsoft.Workflow.Client.WorkflowManager.StartInternal(String workflowName, WorkflowStartParameters startParameters)\r\n   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowManagementClient.StartInstance(String serviceGroupName, String workflowName, String monitoringParam, String activationKey, IDictionary`2 payload)\r\n   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflow(WorkflowSubscription subscription, IDictionary`2 payload)\r\n   at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.StartWorkflowOnListItem(WorkflowSubscription subscription, Int32 itemId, IDictionary`2 payload)\r\n   at Microsoft.SharePoint.WorkflowServices.WorkflowInstanceServiceServerStub.StartWorkflowOnListItem_MethodProxy(WorkflowInstanceService target, XmlNodeList xmlargs, ProxyContext proxyContext)\r\n   at Microsoft.SharePoint.WorkflowServices.WorkflowInstanceServiceServerStub.InvokeMethod(Object target, String methodName, XmlNodeList xmlargs, ProxyContext proxyContext, Boolean& isVoid)\r\n   at Microsoft.SharePoint.Client.ServerStub.InvokeMethodWithMonitoredScope(Object target, String methodName, XmlNodeList args, ProxyContext proxyContext, Boolean& isVoid)\r\n   at Microsoft.SharePoint.Client.ClientMethodsProcessor.InvokeMethod(Object obj, String methodName, XmlNodeList xmlargs, Boolean& isVoid)\r\n   at Microsoft.SharePoint.Client.ClientMethodsProcessor.ProcessMethod(XmlElement xe)\r\n   at Microsoft.SharePoint.Client.ClientMethodsProcessor.ProcessOne(XmlElement xe)\r\n   at Microsoft.SharePoint.Client.ClientMethodsProcessor.ProcessStatements(XmlNode xe)\r\n   at Microsoft.SharePoint.Client.ClientMethodsProcessor.Process()","ErrorCode":-1,"ErrorTypeName":"System.Net.WebException"
},"TraceCorrelationId":"597cba9d-1b29-00d8-13d9-1856016bf83c"
}
]

When trying to publish a workflow from SharePoint Designer 2013, I get this error:

System.Net.WebException: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel. ---> System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure. at System.Net.TlsStream.EndWrite(IAsyncResult asyncResult) at System.Net.ConnectStream.WriteHeadersCallback(IAsyncResult ar) --- End of inner exception stack trace --- at Microsoft.Workflow.Common.AsyncResult.End[TAs

I followed the steps here to export and reinstall the root certificate, but it didn't help (even after iisreset): http://blog.binarybits.net/programming/sharepoint/error-the-root-of-the-certificate-chain-is-not-a-trusted-root-authority-register-spworkflowservice-sharepoint-2013/

I don't remember making any changes to the server so I have absolutely no clue where to look for the problem. Ideas? Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.