We are in the process of upgrading from 2010 to 2013 (little behind I know) and are having a bit of trouble with the evaluation site process.

I already resolved the overly long URLs issue, but now when I run the 'Create Upgrade Evaluation Site Collections Job' it gets stuck. If I look in the SQL I do see that the snapshot was created, but the evaluation site collection/site never gets created and the job gets stuck.

What could be preventing this thing from working?

  • How long you wait? how big the site is(size), any clue in the ULS logs?
    – Waqas Sarwar MVP
    Commented Nov 23, 2016 at 17:16
  • I tried it on another newly mounted database and it again created the snapshot, then the job ran for 30 minutes and succeeded, but the snapshot is now gone and the site collection was not created and the dbo.PreviewSiteRequests table is empty.
    – BSouth
    Commented Nov 23, 2016 at 17:37
  • did you check the ULS logs file?
    – Waqas Sarwar MVP
    Commented Nov 23, 2016 at 17:43
  • also run this command Get-SPSiteUpgradeSessionInfo –ContentDatabase <yourDBname> -ShowInProgress –ShowCompleted –ShowFailed
    – Waqas Sarwar MVP
    Commented Nov 23, 2016 at 17:44

1 Answer 1


We have also found that the timer job that creates these EVAL sites puts a somewhat extensive load on the systems so don't try and run this during the day on a production system. As mentioned above, if you see the request in the SitesPreview table, trying moving the Site Collection into a new database. That will reset the request but do not edit that entry in the table per Microsoft.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.