I tried to Extend Web Application on our WSS 3.0 server and I'm getting 'Service Unavailable' for both new URL and the old/previously working one. (I have done the same process on SharePoint 2010 server - works great).

I've removed the Extended Web Application but same results - old/previously working URL won't load. Getting "Service Unavailable". I've tried rebooting but no difference. This is our production server.

Any pointers/suggestions?

  • 1
    Please check the ULS logs and lets us know the error message
    – Vamsi
    Sep 22, 2011 at 19:26
  • Check the worker process identity login to SQL server
    – Vamsi
    Sep 22, 2011 at 19:27
  • Everything looks good in the logs for the Web App extension up until this - from ULS logs "Precompile: LM/W3SVC/614111562/Root : error: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\236ec9e5\325651fa\App_Web_mblerror.aspx.dbc1c15f.vpmqn8ww.0.cs, 289,'Microsoft.SharePoint.MobileControls.SPMobileErrorLabel' is inaccessible due to its protection level"
    – user4747
    Sep 22, 2011 at 20:08

1 Answer 1


Check the Application pool for the web application in IIS. I've had this problem when the Application pool is stopped. This can happen for several different reasons, but the most common is that the password for the identity used in the App Pool has expired or changed, or the account is locked out in AD.

  • I had checked that & the Application pool for the web app definitely was stopped but after starting it, it gave the same error. The password did change a year or so ago but the server has been rebooted many times since so that shouldn't be the problem, should it?
    – user4747
    Sep 22, 2011 at 20:48
  • Did you check to see how the account looked in Active Directory? Check to see if it was disabled or locked out.
    – Lori
    Sep 22, 2011 at 20:59
  • Unfortunately - the account looks fine. BTW - thanks for your suggestions!
    – user4747
    Sep 22, 2011 at 21:14
  • Central Admin page loads ok. And IIS reports all Application Pools and Web Sites are running. I don't know where else to look....
    – user4747
    Sep 22, 2011 at 21:24
  • It's working now (without the Extended Web App). I re-entered the password for the Application Pool and it's working now. If the password was incorrect, shouldn't this issue have come up before? i.e. every time IIS is restarted? Then I tried once again to extend the Web App. Same symptoms. Re-typed the password and neither old URL nor new would work. Remove extended web app, and original URL works (with password retyping). Confusing but I'll take it for now. I would like to get the Extended Web App setup on this server but I'm done for today. Thanks Lori & Vamsi for your help!!!!!!
    – user4747
    Sep 22, 2011 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.