0

Problem:

I'm having trouble figuring out how to change the name of the web browser tab in SharePoint. I'm trying to have the tab display

  • "CompanyName - Page Title"

Right now the site is displaying

  • "Pages - Page Title"

This is annoying because if you try to bookmark the page its default name is "Pages - Home" and is very confusing for my users.

I have tried to change this in the master page; however, every time I try to change it the site stops functioning because of problems with the master page.

  • How can I implement this change to the masterpage?

Your help is greatly appreciated.

2
  • Check the Page Layout you are using for your site.
  • Open the Page Layout in SharePoint Designer in Advanced mode. Page layouts > Right click Page Layout > Check Out > Right Click Page Layout > Edit in Advanced Mode.
  • Find the code snippet and replace the text "your title here" with your title.
  <asp:Content ContentPlaceholderID="PlaceHolderPageTitle" runat="server">
        your title here
  <SharePointWebControls:FieldValue FieldName="Title" runat="server"/>
    </asp:Content>

Change Browser Tab Title in SharePoint

2

My recommendation would be to make this change in the page layouts as the page layout setting will override what you have in the masterpage. To make the change, find the PlaceHolderPageTitle tag and prefix the ProjectPropery with the hard coded company name.

<asp:Content ContentPlaceholderID="PlaceHolderPageTitle" runat="server">
    Your Company Name - <SharePointWebControls:FieldValue ID="PageTitle" FieldName="Title" runat="server"/>
</asp:Content>
2

You should do this at page layout rather than master page as the following

  • Check page layout out and Edit it in Advanced Mode.

  • At the top of the page look for the PlaceHolderPageTitle placeholder.

  • Type your company name before the PageTitle as the following

[Code]

<asp:Content ContentPlaceholderID="PlaceHolderPageTitle" runat="server">
    Qassas | 
    <SharePointWebControls:FieldValue id="PageTitle" FieldName="Title" runat="server"/>
</asp:Content>

[OutPut]

enter image description here

0

Rather than possibly messing the CSS code up, add a Title in Site Settings: enter image description here

It will add the Title to the page and the tab within the browser.

0

The much simpler method:

  • Click Page on the ribbon
  • Check Out
  • Go back to Page on the ribbon, Go to Edit Properties, click the drop down arrow
  • Edit SEO Properties
  • Change both the 'Title' and 'Browser Title'

This is what worked for me

-1

Go to Pages Library Add Title field to one of your views. Locate file in the view. Change to Quick Edit mode. Update the Title field to new value. Stop editing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.