1

Currently have a SharePoint 2013 on premise system, users are running Windows 7.

The idea is to use SharePoint to store AutoCad drawings, (.dwg).

Out of the box, when opening a dwg file from SharePoint via Internet Explorer, you are prompted to download the file to your downloads folder.

Ideally, we want to be able to open the file straight from SharePoint, enabling users to save directly back, rather than manually re-uploaded the drawing file.

Struggling to make it work this way...

I've added a MIME type to IIS for image/vnd.dwg (used fiddler to check the mime type in the header). I've change the web app to use permissive mode rather than strict (for testing..) - however, files are still being prompted to be downloaded.

Is there anything else I can try?

P.S the test machines opening the files do have AutoCad installed!

Thanks

1

Please follow these steps after the changes you made.

  • check file out the file 1st
  • Now click on the file name and it will open in autocad.
  • when done, hit save. and it auto-checks the file back in. It will likely add a "bak" file to the list.

Referenced here also check this

  • Thanks..I've tried this...but even after checking out the drawing is being downloaded to 'My Downloads' rather than using local drafts.. – user1106196 Nov 15 '16 at 9:11
  • Ok - adding a mapped drive to the library enabled drawings to be opened straight from SharePoint. I believe this is because the workstations are on a different domain. Looking at fiddler, a number of 401's were being thrown... Once the mapped drive was added, the auth was happy. – user1106196 Nov 15 '16 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.