0

Hi I've create mysite successfull but when I try and access the site collection i get this error:

User Profile Application Proxy failed to retrieve partitions from User Profile Application: Microsoft.Office.Server.UserProfiles.UserProfileApplicationNotAvailableException: UserProfileApplicationNotAvailableException_Logging :: UserProfileApplicationProxy.ApplicationProperties ProfilePropertyCache does not have 86be0f20-0a31-4514-ae30-0319f57136a1 at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_ApplicationProperties() at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.get_PartitionIDs() at Microsoft.Office.Server.Administration.UserProfileApplicationProxy.IsAvailable(SPServiceContext serviceContext)

0

This is mostly caused by missing permissions. Please make sure the following service-accounts have full control to your UserProfileService Application:

  • MySites WebApplication Pool account
  • Distributed Cache service account (can be found in services.msc at "AppFabric Caching Service")
  • If it still doesn't work, also add the serviceaccount for the UserProfileService
  • Noted lets say my MySites WebApplication Pool Acc is "Charles" should Charles be used for AppFabric Caching and be added on the UserProfile services? with full control. – Ed Charles Diesel Nov 10 '16 at 11:39
  • Please do not use "charles" as the AppFabric Service Account. You should use a separate account. If you want to change it, please follow the steps described here: technet.microsoft.com/en-us/library/…. – MHeld Nov 10 '16 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.