3

I have a library in office 365 and a SPD 2013 task process approval workflow attached to it.When the workflow is started, new task is created in Workflow Task list.

There is another workflow attached to Workflow Task list which gets started when an item is created. But unfortunately,my workflow doesn't gets starts when new item is created.

But when I manually enters the new task in Workflow Task list then it gets started. But when the item is automatically created in Workflow Task list it doesn't get started.

NOTE: I have tried using System Account and normal user too.But didn't get any success

Any help would be appreciated.

Thanks

  • This post has a similar question here is the Link – sam Nov 9 '16 at 7:06
  • Hi are you get the solution? – Admin Nov 10 '16 at 9:39
  • SP 2010 based workflow invoked automatically while item created using SP 2013 workflow – Hitesh Chandegara Nov 25 '16 at 10:08
3

Since item creation is from system i.e. sharepoint site it is not treating as new item. So workflow not started.

In doc library workflow, after task creation step try to start the workflow of task list.

Refer this link https://blogs.msdn.microsoft.com/sridhara/2014/08/19/fix-sharepoint-2013-workflow-recursion-prevention-part-1/

You need to have at least May 2014 CU for this to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.