0

Our public facing website Arabic version has developed on SharePoint 2013. But after loading the Website when I use Inspect in google chrome I'm getting following errors, and I need to resolve it as early as possible because this is the order by our higher management.

I did research a lot but couldn't find a proper solution so far, But I'm expecting the solution at least from here,

Kindly go through the image and please let me know how to get rid of these type of errors.

Thanks in advance for going through this ad and I highly appreciate those who gives their valuable suggestions to solve the problems.

enter image description here

  • Please add more details about what you are doing in this page, what's the script that you use , to can help you faster ? – Mohamed El-Qassas MVP Nov 5 '16 at 12:30
  • Dear sir, Thanks for your response. This is our website, basically working fine for end users, but sometimes it actually stops working for 3,4 hours then automatically it starts working, the image above shown from the console, and my manager told me to work on it because these can be the reasons of getting the website down. Please if you need anything to know kindly ask me. – Asrar Nov 6 '16 at 6:56
  • Stops working !! are you mean the whole site go down or some pages ? by the way , this error is absolutely not related to any reason to let your site go down , please try to check the log and Event Viewer at the time that site went down and update your answer with what you found out ? – Mohamed El-Qassas MVP Nov 6 '16 at 11:19
  • Yeah entire site goes down automatically, I'm sure thats not because of these errors. But still I want to resolve it. May I please know what to do? – Asrar Nov 6 '16 at 12:52
1

Your screenshot only shows errors in console. Is your site opening? If yes and you are getting these error then here are some thoughts on them:

As from your screenshot, the 404 is the path error. The files needs published (so every user can have access) to be on path.

The second error is syntax error. you can see the line number it is on right side.

If the site is not opening at all, then you need to check IIS settings. Please put more details if you need any other information.

  • Dear sir, Thank you so much for your response. Yeah our website is working fine for end users, but you know sometimes it's getting down and upto 3,4 hours it stops working and suddenly it starts working , thus the reason my manager told me to work on the errors which we can see from the console. So may I please know how to resolve these issues?? – Asrar Nov 6 '16 at 6:52
  • As I explain above, for 404 error you need to add run.prettify.js in your style library or where you place all your other js files and have to provide that path in your code instead loading from google as the path is not reachable. – love thakker Nov 6 '16 at 14:34
  • Thanks for your suggestions sir,I will definitely do that and let you know the results. – Asrar Nov 7 '16 at 5:17
  • Dear sir, Please May I know where I can get run.prettify.js file to download? I researched but getting others but not run.prettify. If you have any link for that then kindly tell me. Thanks – Asrar Nov 7 '16 at 5:34
  • I have searched as per my knowledge from your screen shot and got that files were moved to Github (code.google.com/archive/p/google-code-prettify). In Git I found this file : github.com/google/code-prettify/blob/…. – love thakker Nov 7 '16 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.