Our global navigation has strange behavour.

When user is at startpage on a site the global navigation looks correct, but when same user navigates to a list or site content the global navigation looks different in a incorrect way. How is this even possible?

Startpage at the site:

enter image description here

When you are inside site content or inside a list.

enter image description here

It seems to be a Microsoft issue, the issue occours if user is using the new interface. If you return to the old interface it works! ;)

  • Can you provide some screenshots so we can understand what is happening?
    – wjervis
    Commented Nov 4, 2016 at 14:17
  • @wjervis Take a look I added screenshots
    – Rohander
    Commented Nov 4, 2016 at 14:21
  • What are the navigation settings?
    – wjervis
    Commented Nov 4, 2016 at 14:23
  • @wjervis Structural navigation, show subsites and show pages is not checked.
    – Rohander
    Commented Nov 4, 2016 at 14:40

1 Answer 1


In the Navigation setting (http://spsite/_layouts/15/AreaNavigationSettings.aspx) uncheck the box saying to display pages in the top navigation.

If that doesn't solve your problem, I guess you're suffering from the same error MS has received in User Voice:

"Currently the new document library experience does not support Managed Navigation. It would be great to have this as currently using the structured navigation seems buggy in the new experience. Specifically, it ignores the "hidden" attribute of structured navigation which can make for some large menus. We love the new experience and are hoping to train users up and roll it out however we need to get navigation right before we can do this."

  • imgur.com/p6EgIr4 if you check this link you can see our navigation settings. And I guess it looks just like the way you mentioned. It have not solved the problem. So basicly its a MS bug?
    – Rohander
    Commented Nov 4, 2016 at 14:43
  • @Rohander true ;(
    – Benny Skogberg
    Commented Nov 4, 2016 at 15:29
  • 1
    The issue seems to be new the interface. If you return to classic interface it works! ;)
    – Rohander
    Commented Nov 7, 2016 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.