1

I have a list of promoted links (tiles), around 60, and depending on the AD Group a user is associated with, he/she will have access to just one area (so one promoted link will work for him) and not others. However, when the person gets to the landing page, ALL of the promoted links are shown and if the user clicks on a link that he has no access to, then he'll get a message saying he has no access. This is bad design since if the person doesn't know where he has access, he has to keep clicking until he finds the right tile. I'm just trying to display what he/she is supposed to see. How could I achieve this?

enter image description here

  • 2
    have you already tried to apply custom permissions / trimming on the items in the source list for the promoted links? You didn't state that so I will leave this as a comment for now (and maybe convert it to answer later if needed). While SharePoint won't analyze the urls you are promoting to decide if some should be "trimmed out" (from a design perspective, you could as well have included urls that are external to SharePoint in the first place), it should still enforce whatever visibility the items in the source list it is enumerating define. – SPArchaeologist-様 Nov 3 '16 at 15:54
  • @SPArchaeologist Thanks for the answer, you mentioned "apply custom permissions / trimming on the items in the source list for the promoted links" , honestly I'm not sure how this is accomplished - I could go so many ways on this way. Any hits? THank you! – LearnByReading Nov 3 '16 at 16:13
1

You can achieve this by setting the user/group permission on the list item level in the Promoted list as the following :

  • Go to site contents > open your list > click on All Promoted Links view
  • Now the items should be shown like all items normal list.
  • Select the items that you need to show for a specific people.
  • From the above ribbon > Item tab > select Shared With .

enter image description here

  • Click on Advanced to open permission settings for this list item.
  • Stop Inheriting permission , and set only the users and group that you need to show this link.

Now the links should be shown only based on the user item permission.

  • Thank you for your answer, I get an error saying: "This Control is currently disabled". I should have full permission/access level. Is there a setting I need to change? Thanks again – LearnByReading Nov 3 '16 at 18:19
  • Glad you found my comment useful, at least I won't have to lose time converting it in an answer since you already did it for me. – SPArchaeologist-様 Nov 4 '16 at 18:54
  • Dear @SPArchaeologist your comments / answer always useful :) , and I really repect you, but I found the question owner ask for How he can do this at his comment for you, and because I did this before at my site , I post my answer to help him quiclly and with more details so I am sorry if you feel somthing else where our aim is one (help people) :) – Mohamed El-Qassas MVP Nov 4 '16 at 19:12
  • @LearnByReading , this is not considered an error , this mean you don't have a sufficient permission to do that , so ask your site administrator to do this , or give you sufficient permission to can manage this permission . by going to site setting > user permission > site permission > set your permission as full control , or at least give yu full control for this permission to can manage permission . please don't hesitate to ask for more clarification – Mohamed El-Qassas MVP Nov 4 '16 at 19:23
  • @M.Qassas I actually have full permission/access. I am the site admin, but I still get that message! – LearnByReading Nov 4 '16 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.