2

Have been using SPD2013 to manage a SharePoint site for a good while now. I am not the server admin. Just a site admin.

Anyhow, everything has been going well -- except suddenly I am no longer able to publish a workflow. I can save them, but not publish. I get a workflow error every time:

enter image description here

Couple things I find strange:

  • That path at C:\Users\ does not even come close to existing (no wonder the file can't be found!). There is no SP13PRD_AppOurNet user or folder by that name.
  • The .dll file name is constantly changing every time I get the error. So, I'm guessing it's being dynamically created and maybe never being saved (if that path doesn't exist). I check my user folder at %USERPROFILE%\AppData\Temp\ but there are no .dll files saved there.
  • The workflows currently on the site continue to run as planned; but I can't create a new one or publish changes to old ones. I've tried creating workflows as simple as a single step, simply logging to the workflow history. No dice.

I can't find this error referenced anywhere online. Anyone have any ideas? I tried clearing the cache files and re-starting everything but no luck.

Thanks.

  • It happens some time because of server is busy. try to reset IIS and reopen designer and try Publish – Akshay Dattatray Nangare Nov 3 '16 at 5:02
2

I also face this issue sometimes. Looking at the the error you are getting, below link may help you to solve the issue: SharePoint Designer 2013: Unexpected Error on server associating the workflow

Why we face this issue?

During the workflow publishing phase, SharePoint will create couple of temporary files under the temp folder (of the app pool service account). As part of clean-up process w3wp process will delete this files later.

Sometimes, instead of deleting content inside temp folder w3wp process deletes the temp folder. Because of which workflow publishing fails with “Could not find a part of the path”

How to work around this issue?

Create a text file and provide read only access to file. This will stop process from deleting temp folder.

  1. Navigate to C:\Users\\AppData\Local\Temp on both the server (WFE1 and WFE2)

  2. Create a text file inside the temp folder and in the properties check read-only option.

  3. Reset iis /noforce

  4. Publish the workflow.

  • Thank for the detailed suggestion - I need to work with the IS team as I don't manage the server itself. I will get back to you. – thornomad Nov 3 '16 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.