1

I'm trying to upgrade a SharePoint 2010 Server to Service Pack 2.

When I run the SP2 program i am prompted with a error: The installation of this package failed

Service Pack 2 File: oserversp2010-kb2687453-fullfile-x64-en-us.exe

I've found a blog describing that he had the same issue and it was resolved through using a user with the correct permissions.

But as far as i can understand the user I'm using has the correct permissions.

Does anyone have a list of the required permissions for running this update.

2 Answers 2

1

Couple of things to check:

  1. Check the size of the File and Also right click > check properties > make sure it is not blocked
  2. Make sure file is not corrupted and try to download fresh on different pc and copy over the server.
  3. Open command prompt as Admin and execute it from there
  4. make sure previous upgrades completed properly( config wizard ran successfully)
  5. Check the Logs from the %Temp%( type this in address bar) and you will see file name OPatchInstall.log. get the clue why it is failing.
  6. If you have anyother server try to install SP2 there using the same file.
  7. lastly try to reboot the server.
1
  • I downloaded the file again and now it looks like its working! Nov 2, 2016 at 14:28
1

Your SharePoint Server may be in a state where it's out of sync with the Config_DB. To correct this, you run the script

Get-SPProduct -local

Contrary to what many believe, this script actually writes to the Config_DB, and refresh the upgrade cache to its correct state.

4
  • So I ran the script but I still have the same problem. Is there any other steps to this or might the problem be related to something else? Nov 2, 2016 at 13:56
  • 1
    @GeorgeNorberg Can you see anything in the ULS-logs (using ULS Viewer) or in the Event Logs? Just a quick check, you run the patch as administrator and the account your using is Farm-admin and local admin on the server you're trying to upgrade?
    – Benny Skogberg
    Nov 2, 2016 at 13:58
  • So I looked through the Event Logs and the ULS and nothing related to this problem is logged but good idea with Event logs! The account I'm using has those permissions. I will keep looking for a solution! Nov 2, 2016 at 14:09
  • 1
    I downloaded the file again and now it has atleast started the update. Thanks for the tips anyways! Nov 2, 2016 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.