2

I have a Search result webpart on a site and its behavior is not working correctly.

Here is the Query:

contentclass:STS_Web AND Path:"https://company.sharepoint.com/sites/Projects" AND NOT Title:"Project Template" -ContentClass=urn:content-class:SPSPeople

Basicly what I want to do is to display all subsites that they have permission to see at sitecollection https://company.sharepoint.com/sites/Projects for current user.

It seems like the Query is ignoring some of the subsites.

For example I added myself as owner on 3 subsites, only 2 sites are displayed in the search result webpart which is weird. If I put myself as sitecollection administrator on https://company.sharepoint.com/sites/Projects the search result webpart displays 15 subsites out of 18. There is only one subsite that is getting ignored and it is doing it which is correct.

What may be wrong? Is the Query wrong for achieving what I am looking for?

FYI I have also tried to use following query

contentclass:STS_Web AND Path:"https://company.sharepoint.com/sites/Projects

Its still ignoring some of the subsites. Could it be a indexing problem?

  • 3
    Have you tried adding TrimDuplicates:False option to the query? – Aveenav Nov 1 '16 at 15:34
  • @Aveenav Settings -> Remove duplicates -> "Don't remove duplicates" is choosen. If thats what you mean – Rohander Nov 1 '16 at 15:55
  • 1
    Have you tried removing bits of your query to determine the cause. Start by simplifying it to 'contentclass:STS_Web AND Path="company.sharepoint.com/sites/Projects*". – Matthew McDermott Nov 1 '16 at 21:19
  • @MatthewMcDermott Yes I have tried that, thanks for the tip tho! – Rohander Nov 3 '16 at 22:16
  • Are you defining the AND NOT Title:"Project Template" because you want to exclude some specific site or the root site where these results are shown? – moe Nov 4 '16 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.