0

Farm with 9 WFEs - 6 on primary site, 3 in DR (stretched farm). BLOB cache is enabled on all WFEs.

Have some JS files in the Style Library sub-folder. Versioning with major versions enabled, no approval required. No publishing feature enabled (site or web).

The issue: all the servers in primary location return oldest (first) version of the JS files, while all WFEs in DR return the latest one. Therefore, changing the files doesn't cause BLOB cache invalidation on the primary site WFEs....

Other things already tried:

  • added timestamps to JS file URLs
  • disabled the Minimal download strategy
  • tested in IE and Chrome + cleared browser cache

Any clues what is happening here?

  • Fiddler is your best choice here. You need to see what the response is from the server cache and cache time-wise. Clients also must make a request to a particular server in order for BC to update it's contents. – Trevor Seward Nov 1 '16 at 18:51
2

What i understand Jave script files cached in the user's browser. So there are couple of workarounds which you can think about.

  • Thanks for your answer. I've updated the description with more info. Regarding second bullet point, each change creates a new file version. – Alex Filipovici Nov 1 '16 at 14:47
  • 1
    have u tried flushing the blob cache? – Waqas Sarwar MVP Nov 1 '16 at 14:54
  • that's the last resort. Still no other options so far. – Alex Filipovici Nov 1 '16 at 18:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.