2

We have recently migrated SharePoint 2010 SP1 from Server 2008 to SharePoint 2010 SP2 on Server 2012 R2.

The SharePoint web application runs well but some of the wsp we deployed does not work which contains the custom user control.

When we try to access the page it gives me below error.

10/27/2016 23:21:49.33 w3wp.exe (WFE2:0x1B14) 0x2014 SharePoint Foundation Runtime

tkau Unexpected System.Web.HttpException: Unknown server tag 'asp:ListView'. at System.Web.UI.TagPrefixTagNameToTypeMapper.System.Web.UI.ITagNameToTypeMapper.GetControlType(String tagName, IDictionary attribs) at System.Web.UI.MainTagNameToTypeMapper.GetControlType2(String tagName, IDictionary attribs, Boolean fAllowHtmlTags) at System.Web.UI.MainTagNameToTypeMapper.GetControlType(String tagName, IDictionary attribs, Boolean fAllowHtmlTags) at System.Web.UI.RootBuilder.GetChildControlType(String tagName, IDictionary attribs) at System.Web.UI.ControlBuilder.CreateChildBuilder(String filter, String tagName, IDictionary attribs, TemplateParser parser, ControlBuilder parentBuilder, String id, Int32 line, VirtualPath virtualPath, Type& childType, Boolean defaultProperty) at System.Web.UI... 77f16f77-3b0a-4ce7-969c-4339d5ade3da

After searching on i found that this can be fixed by adding additional Controls tag

It did not resolve the issue. I even checked the .net framework on the new server from server manager > Features which shows .net Framework 3.5 - installed, .net Framework 4.5 features installed (6 of 7 installed) if at all its related to the error.

Appreciate help if anyone has experienced the same.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.